£1.59 Next Day delivery! Hurry ends in ...
  1. Vibrating love egg - help required

    1522968190
    Mr & Mrs Soandso [sign in to see picture]
    • Rank: Officer Cadet
    • Posts: 3
    • Joined: 27 Aug 2016

    I have recently purchased two desire vibrating love eggs. I’ve charged them, sorted the battery in the remote etc. The eggs work but neither handset is syncing with its egg. Any tips as to what I’m doing wrong or is this a problem others have had?  I really wanted to make use of them when I take hubby away next week.

    Thanks!

    Mrs S

    1522972374
    AmyA [sign in to see picture]
    • Rank: General
    • Posts: 545
    • Joined: 21 Feb 2016

    I don't have this particular love egg and you haven't said what you have tried but the ones I've had you press and hold the button on the egg so the stay is on (flashing usually) in standby mode, then do the same on the remote. Once the light is on on both press the remote again to start the vibrations. If you have tried that or if the instructions for that particular egg are different then perhaps new batteries in the remote or check if it has a travel mode?

    1522973362
    Mr & Mrs Soandso [sign in to see picture]
    • Rank: Officer Cadet
    • Posts: 3
    • Joined: 27 Aug 2016

    Thanks Amy

    Ive got the egg in standby mode, that’s working fine. I then have to hold the power button on the remote to sync the two, followed by pressing the + button to check they are synced. It’s at this point that nothing is happening. I will try new batteries, but really don’t think that should be the issue when they’re brand new.

    Ive ordered an alternative product to see if that works.

    1522974124
    AmyA [sign in to see picture]
    • Rank: General
    • Posts: 545
    • Joined: 21 Feb 2016

    I'm sure you have but after they should be sync'd have you tried pressing the power button again instead of the +? Just a single press not long hold.

    1522975357
    AmyA [sign in to see picture]
    • Rank: General
    • Posts: 545
    • Joined: 21 Feb 2016

    Just read through the reviews so heres a couple more ideas, sorry if they sound obvious and you tried them.

    There is a piece of plastic in the battery compartment of the remote, you haven't said if you are getting any lights on the remote or not so have you removed the plastic?

    A couple of the reviews say turn on the remote first (to standby) then the egg, are you doing that of the egg first? Others I've had was the egg first but it might not make a difference.

    Might be faulty but seems strange you have two and neither are working.

    1523197443
    Mr Pheebs [sign in to see picture]
    • Rank: Field Marshall
    • Posts: 3319
    • Joined: 12 Jun 2016

    I remember it taking a while to figure out how to synch it but then it just worked. Maybe pop it back on charge to make sure you haven’t locked it and then try again. If that doesn’t work , chat on the phone to customer support so they can talk you through it?

    Dont give up on them, they’re brilliant.

    Post a reply to this thread

    Please sign in to post messages to the forum.