• Multi Speed Vibe Probs

    1304029634
    Moon420 [sign in to see picture]
    • Rank: Officer Cadet
    • Posts: 3
    • Joined: 15 Nov 2009

    Have had three multi speed vibs (the screw top ones) stop working properly within first couple of uses, first now goes from zero to full vibe only with no inbetween gradient, second and third go from slight vibration stop and then to full vib as you twist the screw top ... what am I doing wrong with them LOL!

    1304030040
    sweetlove666 [sign in to see picture]
    • Rank: Field Marshall
    • Posts: 2008
    • Joined: 17 Nov 2008

    are they different vibes or are they the same product. It would help if you could find them on lovehoney, or name them as different members will have experienced a wide variety of multi speed vibes.

    how are you cleaning them? if they are not waterproof than submersing them might be an issue.

    are the tops on tight enough? or you could even be putting the lids on too tight!

    have you checked them with different batteries?

    1304032089
    Laveila [sign in to see picture]
    • Rank: Field Marshall
    • Posts: 2237
    • Joined: 8 Nov 2010

    Also bullets often have a paper wrapped round the batteries, you should not remove it. But I know the feeling, happened to me as well and that was just with me removing the small disk on top of the batteries.But you should give us more information on what the vibes are. Also if you bought them on Lovehoney, contact the customer service.But only if you bought them within last year.

    1304093473
    Moon420 [sign in to see picture]
    • Rank: Officer Cadet
    • Posts: 3
    • Joined: 15 Nov 2009

    hI

    The first two were tracy cox 7" power vibes, the second was a replacment for the first, the third was a "burning Angel" 7". Both the first and the last developed this prob within first two time of using, havent been submirged and cleaned with a wipe. Thanks for the replies :)

    1304383724
    Divine69 [sign in to see picture]
    • Rank: General
    • Posts: 192
    • Joined: 11 Nov 2010

    hI mOON 420, iPROBABLY CAN'T OFFER MUCH HELP - arrrggh the caps lock key!! Sorry, anyway - yes screwing caps on too tight/ or getting threads crossed can happen - I sometimes get Gliiter Pin Ups bullet not working this way. Try being more gentle?

    U could just be very unlucky ;( But if they are from LH and upto a yr old contact the customer services guys - they REALLY are the bees knees in sorting out problems with toys/products.

    1304383938
    Divine69 [sign in to see picture]
    • Rank: General
    • Posts: 192
    • Joined: 11 Nov 2010

    I mean - I can screw cap on too tight on Pin Ups, not cross thread otherwise it wouldn't work at all! Here's a thought - are you using good batteries? I never used to believe some makes were better than others but I do now! My more expensive toys work proper job with proper good bats in them. Hope this maybe helps??

    1317316933
    Moon420 [sign in to see picture]
    • Rank: Officer Cadet
    • Posts: 3
    • Joined: 15 Nov 2009

    Cheers for all the advice, tried every thing and still have the same prob, ah well ..try a push button one next ;)

    1317399299
    ChoccyHobNob [sign in to see picture]
    • Rank: Officer Cadet
    • Posts: 17
    • Joined: 16 Sep 2011

    You may find that the contact strip has a buildup of oxidation on it.

    This may sound a little odd but try taking the rotating cap off the vibe, dropping it in a glass of alcohol (I use vodka) and turning the cap from 1-100 back and forth for a couple of minutes.

    Take it out of the booze and shake it as hard as you can to get as much liquid out as possible, then dry with a paper towel and leave somewhere warm until absolutely dry inside.

    Don't try this with vodka and coke, it'll get all sticky ;)

    Post a reply to this thread

    Please sign in to post messages to the forum.