• NOTHING WORKS!!!

    1455917316
    Kendal [sign in to see picture]
    • Rank: Lieutenant
    • Posts: 21
    • Joined: 17 Feb 2016

    Hi,

    So I recently purchased my first ever sex toys and they have finally arrived. I have been so excited all day to give them a go but nothing is working properly!!

    First of I have the Lovehoney ladyfinger vibrator. I put in fresh new batteries just to test the vibrations on my skin. It's meant to be multi speed but sometimes it won't vibrate unless I put it on the highest settings.

    Then there's the lovehoney mini rabbit vibrator. If I screw the base back on it won't vibrate at all. Occaisonly it will if the base isn't properly tightened but even then it's hit and miss. Plus the batteries seem to be stuck inside.

    I'm so frustrated. I was really looking forward to trying at least ONE of my new toys tonight X(

    1455917870
    mamz [sign in to see picture]
    • Rank: Field Marshall
    • Posts: 1735
    • Joined: 4 Jan 2016

    You know you can return them for free if you wish? :)

    1455918237

    [suspended user]

    suspended user
    • Rank: Field Marshall
    • Posts: 1375
    • Joined: 4 Dec 2013

    Sorry for your bad experience! I don't have those particular toys myself, but I'm sure it is not standard Lovehoney quality as I do own quite a few other toys from their own brand and other than one rechargeable bullet (now discontinued) I never had issues with anything bought from here. My toys, no matter the price range, always worked properly. I would advise you to have a chat with customer care and I'm sure they'll make it right ASAP! Don't let this unlucky event discourage you ;).

    1455918268
    NatandTom [sign in to see picture]
    • Rank: Field Marshall
    • Posts: 5739
    • Joined: 6 Jun 2015

    Talk to live chat and see what they suggest. It's probably something you could sort out with a quick chat. The ladyfinger is weak on the lowest settings, to the point where it may be working but it isn't enough for you. As for the rabbit, you're not using rechargeable batteries are you?

    1455919201
    Kendal [sign in to see picture]
    • Rank: Lieutenant
    • Posts: 21
    • Joined: 17 Feb 2016

    mamz wrote:

    You know you can return them for free if you wish? :)

    Yeah, it's just that I hope they start working so I won't have to. Have to admit that I am a bit impatient :/

    1455919300
    Kendal [sign in to see picture]
    • Rank: Lieutenant
    • Posts: 21
    • Joined: 17 Feb 2016

    era wrote:

    Sorry for your bad experience! I don't have those particular toys myself, but I'm sure it is not standard Lovehoney quality as I do own quite a few other toys from their own brand and other than one rechargeable bullet (now discontinued) I never had issues with anything bought from here. My toys, no matter the price range, always worked properly. I would advise you to have a chat with customer care and I'm sure they'll make it right ASAP! Don't let this unlucky event discourage you ;).

    I didn't even think about the live chat thanks :)

    1455919411
    Kendal [sign in to see picture]
    • Rank: Lieutenant
    • Posts: 21
    • Joined: 17 Feb 2016

    NatandTom wrote:

    Talk to live chat and see what they suggest. It's probably something you could sort out with a quick chat. The ladyfinger is weak on the lowest settings, to the point where it may be working but it isn't enough for you. As for the rabbit, you're not using rechargeable batteries are you?

    Thanks I'll give the chat a go before I start stressing myself out too much lol

    I'm using ordinary batteries so I don't think my batteries are a problem.

    1455928744
    Kendal [sign in to see picture]
    • Rank: Lieutenant
    • Posts: 21
    • Joined: 17 Feb 2016

    Thanks for all your suggestions. The issues have been solved :)

    1455965857
    Talia [sign in to see picture]
    • Rank: General
    • Posts: 715
    • Joined: 5 Aug 2015

    Solved as in "I'll get new ones" or solved as in "there was a little trick to get them to working which I didn't know about"? In the latter case it would be nice if you could let us know, just in case anybody has the same problem...

    1456711280
    Kendal [sign in to see picture]
    • Rank: Lieutenant
    • Posts: 21
    • Joined: 17 Feb 2016

    Talia wrote:

    Solved as in "I'll get new ones" or solved as in "there was a little trick to get them to working which I didn't know about"? In the latter case it would be nice if you could let us know, just in case anybody has the same problem...

    Hi, sorry for the late reply I didn't see that someone had posted on this thread again.

    Lovehoney replaced the ladyfinger for free since it just would't work. The rabbit on the other hand did start working after I made sure that the base was extra, extra tight. It's a bit fiddly annd i've hardly used it but it seems to be wroking alright :)

    1456712756
    Lovehoney - Paige [sign in to see picture]
    • Rank: Field Marshall
    • Posts: 1120
    • Joined: 28 Mar 2014

    Hello!

    I am sorry you have had troubles! Unfortunately the two products you have purchased do need a little extra trick in order to work.

    The ladyfinger needs a super super tight twist in order to work- tigher than you would think. Funnily enough before I worked for Lovehoney I had this issue, got a replacement, then figured they both worked fine! #oops

    With the mini rabbit, we pop this on the page just to make sure- Please note: If you find it hard to kick-start your new mini rabbit, simply insert one battery + side up and one battery - side up, then replace the battery cap and close it. Now give the cap another twist - they need to be tightly sealed. This usually does the trick.

    I hope this helps a little though it has already been resolved :)

    1456713052
    IHaveArrived [sign in to see picture]
    • Rank: Lieutenant
    • Posts: 9
    • Joined: 11 Oct 2015

    I have a tendency for putting the batteries in the wrong way....I did that with the first toy that I had but after I spoke to someon on chat it was all cleared up and it was faulty and they sent me a new one out straight away :)

    Post a reply to this thread

    Please sign in to post messages to the forum.